Python. Задача 8-9

Текстовый файл состоит не более чем из 106 символов X, Y и Z. Определите максимальное количество идущих подряд символов, среди которых каждые два соседних различны.

Файл Вывод
py-8-8-1.txt 9
py-8-8-2.txt 35
Решение
f = open('c:\\work\\py-8-8-1.txt')
prevsymbol = ''
maxcnt = -1      # Максимальное количество
cnt = 0          # Текущий счетчик
for symbol in f.read():
    if symbol == prevsymbol:
        if maxcnt < cnt:
            # Обновляем максимум
            maxcnt = cnt
        # Сбрасываем текущий счетчик
        cnt = 1
    else:
        prevsymbol = symbol
        cnt +=1
f.close()
print(maxcnt)