Pascal. Задача 8-36

Системный администратор раз в неделю создаёт архив пользовательских файлов. Однако объём диска, куда он помещает архив, может быть меньше, чем суммарный объём архивируемых файлов. Известно, какой объём занимает файл каждого пользователя. По заданной информации об объёме файлов пользователей и свободном объёме на архивном диске определите минимальное число пользователей, чьи файлы нельзя сохранить в архиве..

Входные данные. В первой строке входного файла находятся два числа: S — размер свободного места на диске (натуральное число, не превышающее 10 000) и N — количество пользователей (натуральное число, не превышающее 1000). В следующих N строках находятся значения объёмов файлов каждого пользователя (все числа натуральные, не превышающие 100), каждое в отдельной строке.

Вывести в ответе минимальное число пользователей, чьи файлы нельзя сохранить в архиве

Для решения использовать файл test-8-36-1.txt

Ответ
395
Решение
var
  f : text;
  S, N, i, j, total, tmp : integer;
  a : array[1..1000] of integer;
  str : string;
  sorted : boolean;
begin
  Assign(f, 'C:\PABCWork.NET\test-8-36-1.txt');
  Reset(f);
  Readln(f, S, N);
  total := 0;
  for i := 1 to N do begin
    Readln(f, a[i]);
    total := total + a[i];
  end;
  Close(f);
  // Сортировка по возрастанию методом пузырька
  for i := 1 to N do begin
    sorted := true;
    for j := 1 to N - i do
      if a[j] > a[j + 1] then begin
        tmp := a[j + 1];
        a[j + 1] := a[j];
        a[j] := tmp;
        sorted := false;
      end;
    if sorted then break;
  end;
  // Вычисление количества пользователей
  tmp := 0;
  j := 1;
  for i := 1 to N do begin
    if tmp + a[i] > S then break;
    j := i;
    tmp := tmp + a[i];
  end;
  write((N - j):8);
end.