Python. Задача 8-33

Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [121363; 121431], простые числа. Для каждого найденного простого числа запишите его порядковый номер в заданной последовательности и само число в таблицу на экране с новой строки в порядке возрастания порядковых номеров.

Например, в диапазоне [10; 15] ровно два простых числа, поэтому для этого диапазона таблица на экране должна содержать следующие значения:

2 11
4 13
Ответ
5 121367
7 121369
17 121379
41 121403
59 121421
Решение
# Импортируем функцию квадратного корня
from math import sqrt
for i in range(121363, 121431):
    # Проверяем, является ли число простым
    for j in range(2, int(sqrt(i)) + 1):
        if i % j == 0:
            # Число не простое
            break
    else:
        # Цикл не прерывался, множители не найдены
        print('%2d' % (i - 121362), i)