Pascal. Задача 8-33
Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [121363; 121431], простые числа. Для каждого найденного простого числа запишите его порядковый номер в заданной последовательности и само число в таблицу на экране с новой строки в порядке возрастания порядковых номеров.
Например, в диапазоне [10; 15] ровно два простых числа, поэтому для этого диапазона таблица на экране должна содержать следующие значения:
2 | 11 |
4 | 13 |
Решение
var
i, j : integer;
prime : boolean;
begin
for i := 121363 to 121431 do begin
prime := true;
for j := 2 to i - 1 do begin
if i mod j = 0 then begin
prime := false;
break;
end;
end;
if prime then begin
Writeln((i - 121363 + 1):8, ' ',i:8);
end;
end;
end.