Pascal. Задача 8-34

Системный администратор раз в неделю создаёт архив пользовательских файлов. Однако объём диска, куда он помещает архив, может быть меньше, чем суммарный объём архивируемых файлов. Известно, какой объём занимает файл каждого пользователя. По заданной информации об объёме файлов пользователей и свободном объёме на архивном диске определите максимальное число пользователей, чьи файлы можно сохранить в архиве, а также максимальный размер имеющегося файла, который может быть сохранён в архиве, при условии, что сохранены файлы максимально возможного числа пользователей.

Входные данные. В первой строке входного файла находятся два числа: S — размер свободного места на диске (натуральное число, не превышающее 10 000) и N — количество пользователей (натуральное число, не превышающее 1000). В следующих N строках находятся значения объёмов файлов каждого пользователя (все числа натуральные, не превышающие 100), каждое в отдельной строке.

Запишите в ответе два числа: сначала наибольшее число пользователей, чьи файлы могут быть помещены в архив, затем максимальный размер имеющегося файла, который может быть сохранён в архиве, при условии, что сохранены файлы максимально возможного числа пользователей.

Пример входного файла:
100 4
80
30
50
40

При таких исходных данных можно сохранить файлы максимум двух пользователей. Возможные объёмы этих двух файлов 30 и 40, 30 и 50 или 40 и 50. Наибольший объём файла из перечисленных пар — 50, поэтому ответ для приведённого примера:

2 50

Для решения используйте файл test-8-34-1.txt

Ответ
568 50
Решение
var
  f : text;
  S, N, i, j, tmp : integer;
  a : array[1..1000] of integer;
  str : string;
  sorted : boolean;
begin
  Assign(f, 'C:\PABCWork.NET\test-8-34-1.txt');
  Reset(f);
  Readln(f, S, N);
  for i := 1 to N do
    Readln(f, a[i]);
  Close(f);
  // Сортировка по возрастанию методом пузырька
  for i := 1 to N do begin
    sorted := true;
    for j := 1 to N - i do
      if a[j] > a[j + 1] then begin
        tmp := a[j + 1];
        a[j + 1] := a[j];
        a[j] := tmp;
        sorted := false;
      end;
    if sorted then break;
  end;
  // Вычисление количества пользователей
  tmp := 0;
  j := 1;
  for i := 1 to N do begin
    if tmp + a[i] > S then break;
    j := i;
    tmp := tmp + a[i];
  end;
  write(j:8);
  // Ищем максимально возможный элемент
  tmp := tmp - a[j];
  for i := j + 1 to N do begin
    if tmp + a[i] > S then begin
      writeln(a[i - 1]:8);
      break;
    end;
  end;
end.