Python. Задача 5-8

Найти номера первого вхождения максимального элемента таблицы. Вывести два числа: номер строки и номер столбца, в которых стоит наибольший элемент в таблице. Если таких элементов несколько, то выводится тот, у которого меньше номер строки, а если номера строк равны то тот, у которого меньше номер столбца.

Программа получает на вход размеры массива N и M, затем N строк по M чисел в каждой.

Решение
N, M = map(int, input('Введите количество строк N и количество столбцов  M: ').split())
# Вводим элементы таблицы
a = []
for i in range(N):
    a.append([int(j) for j in input('Введите строку ' + str(i + 1) + ' таблицы: ').split()])
# Ищем максимум
maxn = a[0][0]
row = 0
column = 0
for i in range(N):
    for j in range(M):
        if a[i][j] > maxn:
            maxn = a[i][j]
            row = i
            column = j
print('Максимум в строке', row + 1, ' в столбце', column + 1)