Pascal. Задача 8-8

Текстовый файл состоит не более чем из 106 символов X, Y и Z. Определить и вывести максимальное количество идущих подряд одинаковых символов.

Файл для задачи скачать и сохранить на компьютере. Файл необходимо рассматривать как состоящий из символов.

Решение
var
  f : text;
  ch, pch : char;
  i, m : integer;
begin
  Assign(f, 'C:\PABCWork.NET\test2.txt');
  Reset(f);
  m := 0;
  i := 0;
  pch := ' ';
  while not Eof(f) do begin
    Inc(i);
    Read(f, ch);
    if ch <> pch then begin
      if i > m then m := i;
      i := 0;
      pch := ch;
    end;
  end;
  Close(f);
  if i > m then m := i;
  Writeln('Максимальное количество: ', m);
end.