Python. Задача 8-36

Системный администратор раз в неделю создаёт архив пользовательских файлов. Однако объём диска, куда он помещает архив, может быть меньше, чем суммарный объём архивируемых файлов. Известно, какой объём занимает файл каждого пользователя. По заданной информации об объёме файлов пользователей и свободном объёме на архивном диске определите минимальное число пользователей, чьи файлы нельзя сохранить в архиве..

Входные данные. В первой строке входного файла находятся два числа: S — размер свободного места на диске (натуральное число, не превышающее 10 000) и N — количество пользователей (натуральное число, не превышающее 1000). В следующих N строках находятся значения объёмов файлов каждого пользователя (все числа натуральные, не превышающие 100), каждое в отдельной строке.

Вывести в ответе минимальное число пользователей, чьи файлы нельзя сохранить в архиве

Для решения использовать файл test-8-36-1.txt

Ответ
395
Решение
f = open('c:\\work\\test-8-36-1.txt')
# Считывем из первой строки объем диска и количество файлов
S, N = map(int, f.readline().split())
# Считываем размеры файлов в список
a = []
for i in range(N):
    a.append(int(f.readline()))
f.close()
# Сортируем список по возрастанию
a.sort()
k = 0     # Счетчик файлов
csum = 0  # Текущая сумма
# Максимальное количество поместившихся файлов
for i in range(N):
    if csum + a[i] <= S:
        csum += a[i]
    else:
        # Индекс первого не поместившегося файла,
        # соответствует количеству поместившихся
        k = i
        break
# Минимальное количество не поместившихся
print(N - k)