Python. Задача 8-34

Системный администратор раз в неделю создаёт архив пользовательских файлов. Однако объём диска, куда он помещает архив, может быть меньше, чем суммарный объём архивируемых файлов. Известно, какой объём занимает файл каждого пользователя. По заданной информации об объёме файлов пользователей и свободном объёме на архивном диске определите максимальное число пользователей, чьи файлы можно сохранить в архиве, а также максимальный размер имеющегося файла, который может быть сохранён в архиве, при условии, что сохранены файлы максимально возможного числа пользователей.

Входные данные. В первой строке входного файла находятся два числа: S — размер свободного места на диске (натуральное число, не превышающее 10 000) и N — количество пользователей (натуральное число, не превышающее 1000). В следующих N строках находятся значения объёмов файлов каждого пользователя (все числа натуральные, не превышающие 100), каждое в отдельной строке.

Запишите в ответе два числа: сначала наибольшее число пользователей, чьи файлы могут быть помещены в архив, затем максимальный размер имеющегося файла, который может быть сохранён в архиве, при условии, что сохранены файлы максимально возможного числа пользователей.

Пример входного файла:
100 4
80
30
50
40

При таких исходных данных можно сохранить файлы максимум двух пользователей. Возможные объёмы этих двух файлов 30 и 40, 30 и 50 или 40 и 50. Наибольший объём файла из перечисленных пар — 50, поэтому ответ для приведённого примера:

2 50

Для решения используйте файл test-8-34-1.txt

Ответ
568 50
Решение
f = open('c:\\work\\test-8-34-1.txt')
# Считывем из первой строки объем диска и количество файлов
S, N = map(int, f.readline().split())
# Считываем размеры файлов в список
a = []
for i in range(N):
    a.append(int(f.readline()))
f.close()
# Сортируем список по возрастанию
a.sort()
k = 0     # Счетчик файлов
csum = 0  # Текущая сумма
# Сумма размеров по порядку, которая помещается
for i in range(N):
    if csum + a[i] <= S:
        csum += a[i]
    else:
        # Индекс первого не поместившегося файла,
        # соответствует количеству поместившихся
        k = i
        print(k, end = ' ')
        break
# Уменьшаем текущую сумму на размер последнего поместившегося файла
csum -= a[k - 1]
# Ищем максимальный размер последнего файла
for i in range(k, N):
    m = a[i]
    if csum + a[i] > S:
        k = i
        break
print(a[k - 1])