Python. Задача 8-4

Задана логическая функция F(a, b) = ¬a b. Вывести таблицу истинности функции F(a, b). Необходимо для каждого набора аргументов вычислить и вывести значение функции.

Примечание: В Python 0 приводится к значению False в логических операциях, а 1 - к True.

Для преобразования логического значения в целое можно к 0 прибавить это значение, например:

F = 0 + True  # переменной F присваивается значение 1
Решение
print('a','b','F')
# Перебираем значения переменной a
for a in range(2):
    # Перебираем значения переменной b
    for b in range(2):
        F = 0 + (not a or b)
        print(a, b, F)