Pascal. Задача 8-9

Текстовый файл состоит не более чем из 106 символов X, Y и Z. Определите максимальное количество идущих подряд символов, среди которых каждые два соседних различны.

Файл использовать из предыдущей задачи.

Решение
var
  f : text;
  ch, pch : char;
  i, m : integer;
begin
  Assign(f, 'C:\PABCWork.NET\test2.txt');
  Reset(f);
  m := 0;
  i := 0;
  pch := ' ';
  while not Eof(f) do begin
    Read(f, ch);
    if ch = pch then begin
      if i > m then m := i;
      i := 0;
    end;
    pch := ch;
    Inc(i);
  end;
  Close(f);
  if i > m then m := i;
  Writeln('Максимальное количество: ', m);
end.