Python. Задача 8-35

Системный администратор раз в неделю создаёт архив пользовательских файлов. Однако объём диска, куда он помещает архив, может быть меньше, чем суммарный объём архивируемых файлов. Администратор хочет сэкономить место на диске для хранения архивов и для этого выбирает 4 наибольших по объему архивов и удаляет их, тем самым сэкономив место на диске. Известно, какой объём занимает файл каждого пользователя. По заданной информации об объёме файлов пользователей, определите сэкономленное администратором место.

Входные данные. В первой строке входного файла находится число N — количество пользователей (натуральное число большее 10, не превышающее 1000). В следующих N строках находятся значения объёмов файлов каждого пользователя (все числа натуральные, не превышающие 100), каждое в отдельной строке. Запишите в ответе одно число: сэкономленное администратором место.

Для решения использовать файл test-8-35-1.txt

Ответ
220
Решение
f = open('c:\\work\\test-8-35-1.txt')
# Считывем из первой строки количество файлов
N = int(f.readline())
# Считываем размеры файлов в список
a = []
for i in range(N):
    a.append(int(f.readline()))
f.close()
# Сортируем список по убыванию
a.sort(reverse = True)
# Сумма первых четырех элементов
csum = 0
for i in range(4):
    csum += a[i]
print(csum)